Print Page | Close Window

Tools not visible in Visual Studio

Printed From: Microsoft Dynamics Forums
Category: Microsoft Dynamics SL (Solomon)
Forum Name: SL - Installation and Administration
Forum Discription: Installation, Upgrade, Service Pack, Security, Database, Administration, SQL Server, Login Issues, System Errors, Performance, EDI, Business Portal, and related topics
URL: http://www.MicrosoftDynamicsForums.com/forums/forum_posts.asp?TID=6367
Printed Date: February 21 2020 at 3:25am


Topic: Tools not visible in Visual Studio
Posted By: aviveros
Subject: Tools not visible in Visual Studio
Date Posted: September 05 2012 at 6:41am

Hi, I have a virtual machine with Windows XP, SQL Server 2005, Visual Studio 2005 and Dynamics v.7. Everything works fine, I can design new screens with the VBA Tools, make customizations, etc. But after some period of time (maybe 2 or 3 weeks), Visual Studio doesn't recognize the Dynamics SL SDK objects, like the SAFMaskedText, SAFFloat, etc. If I open a project that contains these objects, it runs fine, I can modify the code and compile it without problems; but I can't add new SDK objects because they are not visible in the Tools box. I have tried reinstalling Visual Studio, Dynamics, changing the .dll references for VBA Tools, etc, but nothing works. The solution for me is to have a backup of the virtual machine and update the virtual machine file with the backup; but this takes time to finish and also, I need to backup all the information that changed in the damaged VM. The same problem occurs with some friends that have the installation in other virtual machines and even in main computers with the complete installation. I will be grateful with any help. Thanks.




Replies:
Posted By: Rohtash Kapoor
Date Posted: September 05 2012 at 7:50am

When you open Visual Studio, go to File --> New --> Project, do you see "DynamicsSL" template under "Visual Basic" project type? If you don't that means you installed Visual Studio after you installed Dynamics SL. One way to try is un-install Dynamics and then re-install and make sure "Dynamics SL SDK" is checked under Tools menu in installation process. The other way is open the project we you are saying is compiling fine, check the reference of "Interop.SAF", add this same reference in your new project. Also, if the controls aren't showing up in Toolbox, right click toobox and click "Choose Items..." and under .NET Framework components select all components starting with "SAF"



-------------


Posted By: aviveros
Date Posted: September 10 2012 at 2:16am
Thanks, I will follow your indications the next time that I can't open the VB Tools. I remember when I have had this problem, I checked the reference of Interop.SAF, but a message appears saying the certificate is not valid. I don't know why, if I can work with the objects for some weeks. I will try the solution you gave me, and I will let you know if it works.


Posted By: aviveros
Date Posted: September 21 2012 at 11:07am

I have just had the same problem with the virtual computer; I opened a project and the SAF controls are not visible in the ToolBox section. However, they are visible in the COM components; I tried to add them manullay. Apparently the tools are available now in the ToolBox, but if I try to add one of them inside the form, I get the following error: “it was not possible to import the ActiveX Control, be sure that the control is registered correctly”.

 
I reinstalled the client, but I am still having missed the SAF tools. The references of these objects are pointed to a folder in c:\windows\assembly . I tried to replace the content of this folder with the files from other machine that has the VBTools, but it doesn't work.

 




Print Page | Close Window