Microsoft Dynamics Forums Homepage

Forum Home Forum Home > Microsoft Dynamics SL (Solomon) > SL - Customization and Integration
  New Posts New Posts RSS Feed - Trouble Using IN Operator with Reports Select Tab
  FAQ FAQ  Forum Search   Register Register  Login Login


Trouble Using IN Operator with Reports Select Tab

 Post Reply Post Reply
Author
Message
dnewman View Drop Down
MicrosoftDynamicsForums.com Member
MicrosoftDynamicsForums.com Member


Joined: October 25 2012
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote dnewman Quote  Post ReplyReply Direct Link To This Post Topic: Trouble Using IN Operator with Reports Select Tab
    Posted: October 25 2012 at 9:39am
I'm running DSL 2011 with Feature Pack 1.

After migrating, we're having a problem with our SSRS based reports.  When we try to use the IN operator on the Select Tab, it creates invalid SQL by adding extra single quotes around the parenthesis and the values.

E.g., when the query should be some.field IN ('test'), it is some.field IN '(''test'')' instead, which invalid SQL.  This causes System Message 6201, Error 56018 ... "Incorrect syntax near '('test')'.

Anyone else seen this?  Is there any way for me to fix it?

Thanks
Back to Top
Sponsored Links


Back to Top
dnewman View Drop Down
MicrosoftDynamicsForums.com Member
MicrosoftDynamicsForums.com Member


Joined: October 25 2012
Status: Offline
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote dnewman Quote  Post ReplyReply Direct Link To This Post Posted: October 30 2012 at 6:39am
In case anyone is interested, this bug has been confirmed by an engineer on the other forums site: https://community.dynamics.com/product/sl/f/35/t/92222.aspx.
Back to Top
 Post Reply Post Reply
  Share Topic   

Forum Jump Forum Permissions View Drop Down


Copyright 2013 microsoftdynamicsforums.com. All rights reserved. MicrosoftDynamicsForums.com is an independent non-Microsoft website.
Email: contact AT microsoftdynamicsforums DOT com